Hola a todos: Hace tiempo que vengo haciendo distintos upgrades, y cada vez que hago uno me encuentro con esto:
Obj http://ftp.fr.debian.org unstable/main Sources
W: GPG error: http://ftp.fr.debian.org unstable Release: The following signatures couldn't be verified because
 the public key is not available: NO_PUBKEY 010908312D230C5F
W: Tal vez quiera ejecutar 'apt-get update' para corregir estos problemas
Esto es debido a que hace ya tiempo que apt incluye un sistema de verificación de paquetes utilizando firma digital GPG. Esta clave se renueva anualmente. Por lo general instalando el paquete "debian-keyring" y añadiendo las claves que contiene el anillo a las claves de nuestro apt bastaba. Esto se hace así:
$ apt-get install debian-keyring
$ apt-key add /usr/share/keyrings/debian-role-keys.gpg
Pero al hacer un update se sigue (o al menos a mi me pasa) que se vuelve a obtener la misma salida de antes. Parece que el paquete no contiene las claves adecuadas. Solución: descargarse en ASCII las claves para este año.
$ wget http://ftp-master.debian.org/ziyi_key_2006.asc -O - | apt-key add - 
Y así se añaden las claves del anillo para este año. ¿ Fácil, no ? Pues, más fácil todavía. En la rama inestable hay un paquete llamado "debian-archive-keyring" que te descarga las claves y las inserta en el anillo de apt y se obtiene el mismo resultado que el anterior. Espero que sirva de ayuda. Un saludo, Arturo.


blog comments powered by Disqus